• iOS 12.1.2再曝新漏洞 将影响新一代全系列 iPhone 机型
  • 发布于 2个月前
  • 105 热度
    0 评论
两位研究人员发现了iOS 12.1.2 中的新安全漏洞,且其影响新一代的全系列 iPhone 机型,包括iPhone XS / XS Max和iPhone XR。Min Zheng和Xialong Bai在 Twitter 上披露了他们的工作细节,演示可通过“面向端口编程”(POP)攻击,获得所有 2018 年发布的iPhone XS Max的 root 访问权限。

该攻击可绕过iPhone XS Max 上的 PAC 系统,不过同样的事情也可以在 XS 和 XR 上完成。

在攻破了 PAC 系统之后,安全研究人员能够更加容易地开发 iOS 12.1.2 的越狱工具,不过这件事情不会很快发生。

近年来,越来越多的用户发现,给 iOS 越狱的好日子,已经接近尾声了。发现操作系统漏洞的安全研究人员,极少会选择将其公之于众。在大多数情况下,研究人员会直接向苹果汇报安全漏洞,然后该公司会在下一次 iOS 更新中修复,以确保 iPhone 的安全机制不被轻易突破。

与此同时,寻求越狱的iPhone 用户数量,也出现了大幅减少 —— 特别是考虑到流程的高度复杂性、以及操作相关的风险。尽管越狱确实能带来一系列好处,但苹果公司显然在坚持打一场不计代价的安全攻防战。即便如此,这些发现仍为其他研究人员研究 A12 仿生芯片中的潜在漏洞(寻找越狱的其它小道)指明了新的方向。毕竟到目前为止,苹果尚未推出过一款牢不可破的 iPhone 。

为什么iOS系统越狱越来越少?

从前,“越狱”是很多买到苹果手机的用户要做的第一件事,因为这样可以获得更高的权限,可以做到苹果预先禁止的功能。十多年前第一代的iPhone,没有游戏、没有任何第三方应用。如果想要安装第三方应用程序和插件,就只能通过“越狱”。而今天的Apple更加关注用户的需求,更加开放。第一代的iPhone甚至都不支持中文,而今天Apple会为中国用户加入农历显示,开放第三方输入法等。

从前只能通过越狱才能实现的功能,如今已经成为了iOS自己本身自带的功能。

正如Cydia之父Saurik所说,“你最后从越狱中得到了什么?过去,拥有杀手级的功能几乎是你拥有iPhone的原因,而现在你越狱只能获得一些小的修改。”Cydia就是越狱的象征,在Cydia商店中用户可以下载或购买各种越狱插件,对自己的iPhone进行个性化。

然而,Saurik在去年12月在Reddit上评论,Cydia已经无法带来任何收入,而且出现了bug,目前已经关闭了购买功能。此外,Saurik已经决定彻底关闭Cydia商店,他自己表示没有继续维护的热情了。

随着苹果为iOS增加了更多的功能,越狱的必要性越来越少。与此同时,iOS越狱也更加困难。对于Saurik而言,这意味着维持商店的成本大于它带来的利益,入不敷出,岌岌可危。

当前的iOS 12.1.2正式版系统据说是为了在国内绕过苹果对高通的侵权专利而匆匆上线的版本,而目前iOS 12.1.3也已发布多版测试,转正在即。

用户评论