• Npgsql already has a dependency defined for System.Runtime.CompilerServices.Unsafe
  • 发布于 1周前
  • 75 热度
    1 评论
  • 吴顺鑫
  • 0 粉丝 39 篇博客
  •   
我在用nuget安装Npgsql插件时,系统报:'Npgsql' already has a dependency defined for 'System.Runtime.CompilerServices.Unsafe'.错误。这个错误是什么意思,该如何解决?
用户评论
  • 林勇
  • 检查一下你项目的.NET Framework版本。目前来看,Npgsql支持以下版本信息:

    .NETCoreApp 3.0
    System.Runtime.CompilerServices.Unsafe (>= 4.6.0)


    .NETFramework 4.6.1
    System.Memory (>= 4.5.3)
    System.Runtime.CompilerServices.Unsafe (>= 4.6.0)
    System.Text.Json (>= 4.6.0)
    System.Threading.Tasks.Extensions (>= 4.5.3)
    System.ValueTuple (>= 4.5.0)


    .NETStandard 2.0
    System.Memory (>= 4.5.3)
    System.Runtime.CompilerServices.Unsafe (>= 4.6.0)
    System.Text.Json (>= 4.6.0)
    System.Threading.Tasks.Extensions (>= 4.5.3)
    System.ValueTuple (>= 4.5.0)


    .NETStandard 2.1
    System.Runtime.CompilerServices.Unsafe (>= 4.6.0)
    System.Text.Json (>= 4.6.0)


  • 2019/9/29 17:03:00 [ 0 ] [ 0 ] 回复